WSL (Ubuntu 18.04) にて Node.js を試す

WSL 環境で Windows のファイルを確認する方法

/mnt/<ドライブレター> にマウントされている。

shwll:例
$ ls /mnt/c/Users/ 'All Users' Default 'Default User' Public user

WSL (Ubuntu 18.04 LTS) 環境に Node.js をインストール

(1) apt で nodejs をインストール

shell
$ sudo apt install -y nodejs Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package nodejs

Unable to locate package nodejs エラー発生。

(2) リポジトリ追加

shell
$ curl -sL https://deb.nodesource.com/setup_10.x | sudo -E bash -

(3) 再度 nodejs をインストール

shell
$ sudo apt install -y nodejs

確認メッセージが表示された。

確認メッセージ
There are services installed on your system which need to be restarted when certain libraries, such as libpam, libc, and libssl, are upgraded. > libpam、libc、libsslなどの特定のライブラリがアップグレードされたときに再起動する必要があるシステムにインストールされたサービスがあります。 Since these restarts may cause interruptions of service for the system, you will normally be prompted on each upgrade for the list of services you wish to restart. > これらの再起動はシステムのサービスの中断を引き起こす可能性があるため、通常、再起動するサービスのリストをアップグレードするたびにプロンプトが表示されます。 You can choose this option to avoid being prompted; instead, all necessary restarts will be done for you automatically so you can avoid being asked questions on each library upgrade. > このオプションを選択して、プロンプトが出されないようにすることができます。 代わりに、必要なすべての再起動が自動的に行われるため、ライブラリのアップグレードごとに質問されることを回避できます。 Restart services during package upgrades without asking? > 確認せずにパッケージのアップグレード中にサービスを再起動しますか?

<Yes> を選択。

(4) node バージョンを確認

shell
$ node -v v10.19.0

(5) npm コマンドもインストール

Windows と違って nodejs をインストールしても npm はインストールされなかった。

[ 追記 ]
WSL shell を exit して、再度 WSL を起動すれば npm コマンドは使用できると思われる。

以下、無駄に npm をインストールしようとした記録。

yarn でもいいけど一旦 npm をインストールする。

shell
$ sudo apt install npm Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. > 一部のパッケージをインストールできませんでした。 This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: > 次の情報は、状況の解決に役立つ場合があります。 The following packages have unmet dependencies: > 以下のパッケージには、満たされていない依存関係があります。 npm : Depends: nodejs but it is not going to be installed Depends: node-abbrev (>= 1.0.4) but it is not going to be installed Depends: node-ansi (>= 0.3.0-2) but it is not going to be installed Depends: node-ansi-color-table but it is not going to be installed Depends: node-archy but it is not going to be installed Depends: node-block-stream but it is not going to be installed Depends: node-fstream (>= 0.1.22) but it is not going to be installed Depends: node-fstream-ignore but it is not going to be installed Depends: node-github-url-from-git but it is not going to be installed Depends: node-glob (>= 3.1.21) but it is not going to be installed Depends: node-graceful-fs (>= 2.0.0) but it is not going to be installed Depends: node-inherits but it is not going to be installed Depends: node-ini (>= 1.1.0) but it is not going to be installed Depends: node-lockfile but it is not going to be installed Depends: node-lru-cache (>= 2.3.0) but it is not going to be installed Depends: node-minimatch (>= 0.2.11) but it is not going to be installed Depends: node-mkdirp (>= 0.3.3) but it is not going to be installed Depends: node-gyp (>= 0.10.9) but it is not going to be installed Depends: node-nopt (>= 3.0.1) but it is not going to be installed Depends: node-npmlog but it is not going to be installed Depends: node-once but it is not going to be installed Depends: node-osenv but it is not going to be installed Depends: node-read but it is not going to be installed Depends: node-read-package-json (>= 1.1.0) but it is not going to be installed Depends: node-request (>= 2.25.0) but it is not going to be installed Depends: node-retry but it is not going to be installed Depends: node-rimraf (>= 2.2.2) but it is not going to be installed Depends: node-semver (>= 2.1.0) but it is not going to be installed Depends: node-sha but it is not going to be installed Depends: node-slide but it is not going to be installed Depends: node-tar (>= 0.1.18) but it is not going to be installed Depends: node-underscore but it is not going to be installed Depends: node-which but it is not going to be installed E: Unable to correct problems, you have held broken packages. > E:問題を修正できません。壊れたパッケージを保持しています。

(6) WSL shell を閉じて、再度 WSL を起動したところ、npm コマンドが使用できた

shell
$ npm -v 6.13.4

WSL (Ubuntu 18.04 LTS) 環境にて gcloud コマンドで google/cloud-run 環境にデプロイする

(1) gcloud コマンド使えた

WSL 環境に gcloud コマンドをインストールすることなく使えた。
既に Windows 環境で gcloud コマンドを使えるようにセットアップ済みだったためと思われる。

shell
$ gcloud -v Google Cloud SDK 261.0.0 beta 2019.05.17 bq 2.0.47 core 2019.08.30 gsutil 4.42

(2) gcloud ログイン

shell
$ gcloud auth login Go to the following link in your browser: > ブラウザで次のリンクに移動します: https://accounts.google.com/o/oauth2/auth?code_challenge=**** Enter verification code: > ブラウザでログインした後に表示される verification code を入力。

(3) google/cloud-run で実行するために google/cloud-build でビルド

shell
$ gcloud builds submit --project <プロジェクト名> --tag <タグ名>

(4) google/cloud-run にデプロイ

shell
$ gcloud beta run deploy <デプロイ名> \ --project <プロジェクト名> \ --region asia-northeast1 \ --image <タグ名> \ --allow-unauthenticated \ --platform managed \ --memory 256Mi \ --set-cloudsql-instances <google/cloud-sql用のインスタンス名>
広告欄
WRITTEN BY
SERIES
この記事に連載はありません。
READ NEXT
COMMENTS
コメント機能は開発中です。実装完了まで今しばらくお待ちください。